Mise à jour importante de PackageKit

Si vous rencontrez les symptômes suivants avec l’AppCenter, ces prochaines lignes devraient vous intéresser :

  • Aucune mise à jour à installer
  • Lorsque vous tentez d’installer un logiciel déjà installé, celui-ci apparaît comme non installé

Elementary utilise une version patchée de la librairie packagekit : le patch en question concerne une fonction supprimée car non utilisée dans l’OS se nommant get-distro-upgrades. Ce patch posait problème car malgré toute l’attention portée aux différents contrôles, certaines parties du code en faisait usage.

Ce bug ‘dormant’ a semble t-il été déclenché suite à la libération de la dernière version d’Ubuntu 17.04.

Pour corriger ce comportement non souhaité, David & Rico ont pu réaliser un patch de cette librairie au travers d’une mise à jour.

Comment installer cette nouvelle version de PackageKit :

Depuis Terminal, il vous faudra procéder à une mise à jour manuelle via les commandes suivantes :

sudo apt-get update
sudo apt-get install packagekit

Une fois l’installation terminée, un redémarrage de votre ordinateur sera nécessaire pour finaliser toutes les opérations.

Packagekit nouvelle version
Packagekit nouvelle version

 

Vous pourrez trouver plus d’informations sur cette page : https://github.com/elementary/appcenter/issues/215

1 2 3