Mise à jour importante de PackageKit

Si vous rencontrez les symptômes suivants avec l’AppCenter, ces prochaines lignes devraient vous intéresser :

  • Aucune mise à jour à installer
  • Lorsque vous tentez d’installer un logiciel déjà installé, celui-ci apparaît comme non installé

Elementary utilise une version patchée de la librairie packagekit : le patch en question concerne une fonction supprimée car non utilisée dans l’OS se nommant get-distro-upgrades. Ce patch posait problème car malgré toute l’attention portée aux différents contrôles, certaines parties du code en faisait usage.

Ce bug ‘dormant’ a semble t-il été déclenché suite à la libération de la dernière version d’Ubuntu 17.04.

Pour corriger ce comportement non souhaité, David & Rico ont pu réaliser un patch de cette librairie au travers d’une mise à jour.

Comment installer cette nouvelle version de PackageKit :

Depuis Terminal, il vous faudra procéder à une mise à jour manuelle via les commandes suivantes :

Une fois l’installation terminée, un redémarrage de votre ordinateur sera nécessaire pour finaliser toutes les opérations.

Packagekit nouvelle version
Packagekit nouvelle version

 

Vous pourrez trouver plus d’informations sur cette page : https://github.com/elementary/appcenter/issues/215

Encore plus de mises à jour pour Loki

Posté dans : Actualités | 0

Loki a encore eu droit à plusieurs mises à jour récemment.

Corentin a rajouté une fonction toute bête dans Paramètres Système, dans la zone de recherche il est possible d’accéder à l’onglet correct de plug Sécurité & Vie Privée avec les termes pare-feu, verrouillage et confidentialité.

Lire la suite

Loki Beta 2 est là !

Posté dans : Actualités | 0

Même si cela fait à peine un mois que la Beta 1 est sortie, plus de 70 problèmes reportés par les utilisateurs ont été résolus. Les utilisateurs de la Beta 1 doivent vérifier que leur système est bien à jour afin de bénéficier de toutes ces corrections plus les celles indiquées sur cette page

Quelques unes des corrections sont des changements de configuration et celles-ci ne seront pas visibles pour les testeurs de la Beta 1. Pour recevoir en bonne et due forme toutes ces corrections, il est hautement recommandé de faire une installation propre avec la Beta 2.

Lire la suite

1 2 3